Actualización fallida

Esta tarde estaba probando el servidor para ver cuánta cpu gastaba, ya que hay varios bloggers que han tenido problemas con WordPress, y he recordado la entrada de marcoss para optimizarlo. Básicamente son dos cosas: optimizar la base de datos con regularidad y cachear los archivos que sirve WordPress mediante un plugin.

De paso le he colocado al tema la función para saber cuánto tarda en generar la página, a ver si es algo excesivo o no. Después de mucho probar, la media se queda alrededor del medio segundo, que no está nada mal, y es que tengo las tablas muy limpitas.

Como creo que se puede mejorar ese tiempo, había pensado en instalar el plugin para cachear los archivos, pero una voz me ha dicho «oye, ya que te vas a poner a instalar cosas en el blog, por qué no instalar la nueva versión de WordPress, la 2.0″. Además, tenía entendido que era más rápido y que utilizaba caché.

Ya está instalado y el resultado es… una mierda. Ok, el diseño ha mejorado y tiene chorradas que molan, pero que no voy a utilizar. ¿Y la rapidez? He hecho la media y es… hasta tres veces más lento que la antigua versión, vamos, una ganga.

Así que escribo esta entrada como recordatorio de que la versión 2.0 es penosa en cuestión de rendimiento y la caché no sé para qué le sirve. Encima antes lo tenía en castellano, y ahora en inglés, por lo que debería gastar menos (no tiene que «traducir» cada vez que lo llaman). En fin, que no se la recomiendo a nadie.

Hala, a volver a instalar la antigua versión (no me lo creo, hice un backup completo, mi primera vez!!).

Actualización: después de un buen rato, ya estoy otra vez con wordpress 1.5, y he tenido que volver a escribir esta entrada, menos mal que mcdave la tenía en su newsgator 🙂

7 alegres comentarios ↓

#1 cumic el día 01.11.06 a las 5:34 am

Bueno, wp-cache 2.0 ya está funcionando (gracias a nuestro amigo Ricargo Gallir). Solo queda probar a ver cómo funciona, si me recarga la página al comentar, por ejemplo…

#2 cumic el día 01.11.06 a las 5:34 am

Buas, ferpecto 😀

#3 balmasedano el día 01.11.06 a las 4:41 pm

Pues yo me quedo con WordPress 2.0, me parece mucho más cómodo. Además, como el blog en el que escribo es colectivo (ejem, aunque sólo escribo yo, por eso ya parece hasta mío), lo mejor es que el editor de posts sea gráfico, que la gente se lía.
En fin, WordPress 2.0 trae algunas cosas interesantes, y a pesar de su lentitud, el 1.5 me parece feo y algo incómodo.
Saludos 😉

#4 Alberto A-P el día 01.12.06 a las 9:51 pm

Sí, WP2 es más lento, pero como dice el de Balmaseda, es más bonito. Yo me lo he instalado, pero he desactivado el WYSIWYG y he dejado el que venía usando hasta ahora, el de MudBomb, que tiene un gestor de imágenes más cómodo y también está basado en TinyMCE.

#5 cumic el día 01.12.06 a las 10:50 pm

Buas, el plugin de wp-cache es la leche… Ahora este blog solo gasta 10 minutos de cpu al día, cuando antes, después de optimizarlo todo, gastaba 25 minutos o así 😀

#6 Averia el día 01.12.06 a las 11:25 pm

Hola cumic, una pregunta, ¿cómo puedo saber lo que estoy gastando de cpu?

#7 Skeku el día 01.19.06 a las 8:37 pm

Aquí tienes a otro feliz usuario de wp 1.5+optimizador de tablas+wp-cache.

Tenía pensado actualizar a la 2.0 pero hasta que no vea algun plugin que me interese y lo necesite, no pienso hacerlo. Criterion va perfect bajo la config antes mencionada 😉

Deja tu comentario

Si tienes una cuenta OpenID, también lo puedes usar, así no tienes que rellenar los campos de arriba: